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Formatting Report Output in Excel® 

Overview 

This course describes the steps used to export data from a user-defined data table report to Excel® and 
then manipulate the data once it’s imported. Other DI Report Writer objects use similar data export 
methods, and, if opened in Excel®, would then use the same manipulation techniques as described in 
this document. 

 

Session Format 

• Lecture 

• Handouts 

• Practice Exercises 

 

Learner Outcomes 

• Define the DI Report Writer vocabulary tools utilized in analyzing a report request and building 
reports to support trauma and performance improvement program needs 

• Demonstrate understanding of reporting principles by successfully applying the learned 
vocabulary tools to the report writing and generation process 
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Export Data to MS Excel® 

Follow these instructions to export a Data Table Report to MS Excel®: 

 

1. Select the User radio button on the Run Report screen, and then click Report. 

 

 

 

 

2. The User Report Manager screen appears. Double-click the Data Table Report  
you want to run.  

 

Note: Any defined Data Table Report can be sent to Excel when created. On the Data Table Editor 

screen, select CSV, Include Column Headings, and Launch Excel, as shown below. 

 

Save the Data Table Report as an Excel Workbook 

Notice that the document’s title is SCREEN.CSV. To preserve formatting changes, you will need to save 

the document as an .xls or .xlsx file.  

 

 

 

 

1. Click the Save button in the Excel ribbon. 

2. An Excel message appears. Click No. 

3. Choose where to save the report. 
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Note: The default location for RW reports is the RW\NODES\NODE0001 folder. You can navigate through 
the network by clicking the dropdown at the top of the Save As window. You can quickly save documents 

to your Desktop or Documents by selecting them on the left side of the Save As window.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Click the Save as type dropdown and select Excel Workbook.  

(In most versions of Excel, it’s the very first option). 
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5. Type your file name in the File name: field and click Save.  

 

Format Your Spreadsheets 

Autosize Columns 

Occasionally, the default width of a column will not show the data in its entirety. ##### may appear 
instead of your data. In these cases, you’ll need to adjust the columns to view the data. You can auto 

size all of the columns at one time. 

  

 

 

 

 

1. Click the box to the left of Column A and directly above Row 1. 
The entire document will highlight. 

 

2. Double-click any column divider line.  

All columns will auto size to the largest width. Notice the #### has been replaced with your 

data.  

 

 

 

 

 

Wrap Text 

Some column headers may be longer than others or longer than the data in its column. In these cases, 

the column header text can be wrapped within the cell to shorten the width of the column.  

 

1. Select your entire spreadsheet by clicking the box to the left of 
Column A and directly above Row 1. The worksheet will highlight.  
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2. Right-click anywhere on your spreadsheet, and then 
select Format Cells… 

 

 

 

 

 

 

 

 

 

 

 

3. Click the Alignment tab. Select Wrap 
text and click OK. 

 

 

 

4. Click anywhere on your spreadsheet to 
deselect it. 

 

 

 

 

 

 

 

 

 

5. Drag any column divider to resize the columns. The divider will resize the column to the left.  
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If the cell doesn’t auto-adjust, double-click between rows (row divider) to resize the row above.  

 

 

 

Freeze Panes 

It can be helpful to see the column headings of a spreadsheet as you are scrolling through the document. 

By default, the header row is visible until you scroll down through the spreadsheet, as shown below.  

 

 

To freeze only the header row, click the View 

tab, then click Freeze Panes and select 

Freeze Top Row. 
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To freeze only the first column, click the 
View tab, then click Freeze Panes and 

select Freeze First Column. 

 

 

 

 

 

 

 

To freeze both a row and a column, click into the cell below the row you want to freeze and to the right 

of the column you want to freeze.  

In this instance, click into cell B2 to freeze column A and the top 

row with your headers.   

Click the View tab, then click Freeze Panes and select Freeze 

Panes. 

 

 

 

 

 

 

 

 

 

 

Now when you scroll through your spreadsheet, the information in your top row and first column will 

remain in place.  



 

Formatting Report Output in Excel® 
 

 

Copyright © 2018 Digital Innovation, Inc.  All Rights Reserved 8 

 

AutoFilters 

Activate Filters 

AutoFilters will create drop down options in each column and allow you to filter on specific values. 
AutoFilters make it easy to find and work with only those rows of the spreadsheet that contain the 

selected values in the filtered column.  

1. Click on any cell that contains data on your spreadsheet. (An error message will appear if you 
select an empty cell). 

 

 

 

 

 

2. On the Data tab, click Filter. 

 

 

 

 

 

3. A down arrow button now appears in each column header. This will be used to filter values on 
the spreadsheet.  

 

 

 

 

 

 

Use AutoFilters 

AutoFilters can be used to select/deselect specific values in a column. The rows containing the specified 
values will display, and the other rows will be hidden. The hidden rows can be returned by turning off 

AutoFilters or selecting different values. 

Scenario 

The Trauma Coordinator would like to identify patients with a Blunt Injury and a Discharge Status Dead.  

You can use any data table report that contains the injury type and discharge status fields to fulfill this 

request using AutoFilters.  
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1. Click the down arrow in the Injury Type column. 

2. To narrow your results to only Blunt injuries: 

a. Deselect all values except Blunt and click OK.  

or 

b. Click (Select All) to deselect all values, and then select 
Blunt. Click OK. 

3. Click the down arrow in the Discharge Status column.  

4. Deselect Alive and click OK.  

 

 

 

 

 

 

 

 

 

 

 

 

5. Review the data. 

Notice the gaps in row numbers. Any row that contains an injury type other than Blunt and 

discharge status of Alive is now hidden. A funnel now appears in the filtered columns where 

down arrow appeared previously.  

 

Use Filters to Create Additional Worksheets 

Filters work well to show a group of records temporarily, but moving the results to a different worksheet 

will create a permanent place for the filtered records. 

Scenario 

The Trauma Coordinator would like all blunt injury deaths on one worksheet and all penetrating injury 

deaths on a separate worksheet. 
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1. Use the down arrow buttons to filter on Blunt injuries and discharge status dead. 

2. Select the entire worksheet by clicking the cell to the left of 
Column A and directly above Row 1 or clicking and dragging to 
highlight the appropriate cells.  

 

 

 

3. Right-click anywhere in the highlighted area and select Copy. 

The results should be many dotted groups separated at the gaps in data, similar to what is 

pictured below. 

 

 

 

 

 

 

 

 

4. At the bottom of the worksheet, click the  next to 
the tab labeled SCREEN to create a new worksheet.  

5. Right-click into the blank worksheet and select Paste.  

 

Now there is a separate worksheet that displays only blunt injuries resulting in death.  

Rename Worksheets 

There are now two worksheets labeled with non-descript default names. Rename the worksheets to 

indicate the information that each worksheet contains.  

 

1. Double-click on the tab labeled Sheet1.  

2. Type a new label; for instance, Blunt Deaths. 

3. Double-click on the tab labeled SCREEN. 

4. Type a new label; for instance, All Patients.  



 

Formatting Report Output in Excel® 
 

 

Copyright © 2018 Digital Innovation, Inc.  All Rights Reserved 11 

 
Change Filter Parameters/Restore Rows 

To change what filtered data is displayed on your Data Table Report, click 
the funnel in the column you want to change. Select a different choice, 

and deselect the current choice (in this example, Blunt). Then click OK.  

 

To restore your columns to show all values, 

including those that were hidden by 
AutoFilters, click the funnel that appears in 

your filtered column and select Clear Filter 

From “Injury Type.” Repeat for all filtered 

columns.  

 

 

 

 

 

 

To remove the AutoFilters from all columns, go to the Data tab 
and deselect Filter. All of the down arrow buttons will be 

removed from your columns.  

 

Use Formulas 

Excel has many formulas that you can use to assess or manipulate your data. Average is a useful formula 

that you can use to analyze the data in a Data Table Report.  

Average 

The Average function returns the average, or arithmetic mean, of your selected data. Average is 

calculated by adding a group of numbers and then dividing by the count of those numbers. 

To calculate the average age of your patients: 

 

1. Locate the Age column and scroll to the bottom.  

2. Select the empty cell under the last age value. 
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3. On the Formulas tab, click AutoSum, and then 
select Average.  

4. Confirm that each cell in your selected range contains 
data. If a row is missing a value, the formula will not 

include any values before that point in its calculation. 

See example below. If there is missing data, you can 
manually change the formula range to include the full 
list of values. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Press Enter to perform the calculation.  

 

To calculate the average ISS for blunt injuries resulting in death: 

 

1. Open the Blunt Deaths tab on your worksheet.  

2. Select the empty cell under the last entered ISS value. 

3. On the Formulas tab, select AutoSum and then select Average. 

4. Confirm that the formula’s cell range contains all of 
the cells in your ISS column (as described above). 
Manually change your cell range if necessary.  

5. Press Enter to perform the calculation. The 

average displayed is the average ISS for blunt 
injury deaths. 

 

 

 

 

You can manually change 

the range of values by 

typing the correct cell 
range into the Average 

formula, as shown here. 

Because cell F8 doesn’t 

contain a value, the 

Average formula will only 
include cells F9 to F13.  
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Data Table Reports—Pivot Tables vs. Statistics Reports 

Pivot Tables Statistics Reports 

May contain detailed patient information as well 

as statistical analysis 
Can only contain statistical information 

Can run one large report from RW and use 

Excel® to divide up the statistics 

Have to run a separate report for each statistical 

chart 

Graphs, charts, and aesthetic changes can be 

retained from use to use 

Graphs, charts, and aesthetic changes have to be 

made every time 

 
Build Your Data Table Report for Statistical Analysis 

Pivot Tables are used to analyze data quickly.  This feature in Excel® is a good way to summarize, 

analyze, explore, and present data. 

Scenario 

The research team has requested some analysis on deaths for the past 2 years. They would like to see 

graphical information on the following criteria, with dates based on patient arrival: 

• Count and percent of deaths by year 

• Count and percent of deaths by month 

• Count and percent of deaths by ISS 1-9, 10-15, 16-24, and >=25 

 

Data Table reports often include the entire Date of Arrival as one field. In order to fulfill this report 
request, separate lines will be included for arrival year (PAT_A_DATE_Y) and arrival month 

(PAT_A_DATE_M_AS_TEXT).  

 

The request will also require you to separate the ISS into ranges using a Coded Variable.  

 

In this example, ISS_SV creates the four ISS ranges as 

defined in the request. 
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Data Table Example 

Create your Data Table report with all of the requested fields, along with some basic patient information. 

See example below.  

 

 

 

Follow the steps on page 3 to export your report to MS Excel®. 

Start a New Pivot Table 

1. Select your entire spreadsheet by clicking the box to the left of 
Column A and directly above Row 1. The worksheet will highlight.  

 

 

 

 

2. Click the Insert tab, and then select 

Pivot Table. A Create Pivot Table 
dialog appears (see next page). Click 
OK. 

 

 

 

Coded Variables for ISS Ranges 

Patient arrival year and month 
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The following screen appears: 
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Select Data for Your First Pivot Table 

The first data request in our scenario was for a count and percent of deaths by year. A pie chart is an 

excellent tool to illustrate percentage, and it is best derived from a Pivot Table that only contains Rows.  

 

1. Click and drag the Discharge Status field to the ROWS box.  

 

 

 

 

 

 

 

 

 

 

 

2. Click and drag a record reference field to the 
VALUES box. In this example, use Discharge 

Status, since all records contain a value. The 
field is also non-numeric and will return a 
count.  

 

 

 

 

 

 

 

The completed Pivot Table (containing both years). 
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Remove Unnecessary Rows  

A Pivot Table may contain unnecessary row values. In this 

example, there is a row labeled Blank without a total. This 

row can be removed.  

1. Click the drop down arrow next to Row Labels. 

2. Deselect the value (blank) and click OK. 

 

 

 

 

 

 

 

Create a Graph 

A pivot table can be made into a Chart/Graph.  

1. Select any cell within the Pivot Table. The PIVOTTABLE TOOLS menu will appear in the toolbar. 

 

2. On the PIVOTTABLE TOOLS tab, select Analyze and then select PivotChart. 

 

3. Select the desired chart type. For this example, select pie chart because they display percentages 

best. 

Add Percentages to Your Graph 

1. Right-click the pie chart. Select 

Add Data Labels, and then 

Add Data Labels. 
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2. The newly added labels appear. When selected, the label boxes have circles on the corners. The 
circles indicate the area of focus within the graphic, which is accessible to modify. With the labels 

selected, select Format Data Labels.  

 

3. Select Percentage and deselect Value. 
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Practice Exercises 

1. Create a Data Table Report with at least five data elements, including Post ED Disposition. Send 

the report to Excel and Filter the data by Post ED Disposition.   

a. Create a tab for each Post ED Disposition and put the records associated with each in 

their tab 

b. Use word wrap and adjust the column widths to make the output look its best 

2. Create a Data Table Report that includes Initial Vitals. Once run to Excel, produce Avg RTS and 

GCS. 

3. Create a Data Table Report that includes ED LOS, Total ICU Days, Vent Days and Hospital LOS 

and Trauma Response Level.   

a. Separate each response level on a separate tab 

b. Find the Avg ED LOS, Total ICU Days, Vent Days and Hospital LOS for each response 

level 

c. Use word wrap and adjust the column widths to make the output look its best 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


